CameTooFar

A Nerd's False Positive.

How to fix green color while playing YouTube, Facebook or flash video

Ah, my god! That happened so quickly. Something thing I never experienced before and was really surprising when all the flash videos that I streamed started to turn green in my Windows 8 PC. Though I can hear the audio clearly, the video was playing in green color. I experienced this first when I went to YouTube. All the YouTube videos I streamed was playing in green color, like below:

image

IE being my default browser, I tried in Firefox. The fox even hauled the video in green. While Binging for a solution, I came across lot of articles and blog posts saying various reasons. Here goes the list of solutions:

1. Update flash player

2. Turn off hardware acceleration for flash, by right-clicking on the flash video –> general settings –> uncheck ‘enable hardware acceleration’. This works, if you are using non-IE browsers. However, if you are using IE, then your need to uncheck ‘use software rendering instead of GPU rendering’ from your Tools –> Internet Options –> Advanced (Tab) (screenshot below)

3. Update video driver to the latest version

4. Disable Hyper-V. I stuck at this point for some time because I installed Windows Phone SDK for development purpose some times back and yes, it requires Hyper-V

5. Uninstall Windows update KB2735855 and install the hot-fix KB2789397

6. Anti-virus (Nod32) problem

Thus goes the long long list. I updated my video driver to latest version. But, didn’t helped at all. What surprised me was, I can successfully play flash videos in Google Chrome (though I rarely use it), which confirmed that it’s not a video driver issue. I concluded that it could be a flash player issue.

But, shocking surprise was awaiting when I checked Adobe’s website for downloading the latest flash player. I can see only a long list of instructions, do’s and don’t do’s and some Windows update to install. But, never it showed any download link for the latest flash player :(

Half-heartedly, I unchecked ‘use software rendering instead of GPU rendering’ in IE and restarted the browser to fix the issue.

image

I said, half-heartedly because my PC has dual graphic card. So, I’s not ready to bring the rendering load onto my CPU while playing with the browser.

After hours and hours of searching, I managed to find the direct download link to the latest Adobe Flash Player. Installed it and yes, the flash videos are working as normal. Here goes the link for Adobe Flash Player 11 - http://aihdownload.adobe.com/bin/live/install_flashplayer11x32_mssd_aaa_aih.exe, in case if you didn’t find the link.

Hope this helps.

Thanks.

SMF Player not playing video in Windows Phone 7 device

Last week, I’s working on an almost ready Windows Phone project which streams video in SMF (Silverlight Media Framework) Player, for adding some additional features. After the feature integration, I tested it thoroughly in Emulator. To see the app behavior in a real device, I deployed the app on to my Windows Phone 7 device. Bang!!! Nothing is playing. When I try to load video, the player stays still - no audio, no video, not even any video/media related SMF Player events are fired at all. After spending hours of investigation, my colleague pointed out that I haven’t installed Smooth Streaming Client 2.0 on my developer machine.

Installed it, deployed the app to my device. And, Yup! The video starts playing Smile

Did you ever got stuck for hours for silly issues? Winking smile

How I solved Windows 8 wi-fi connectivity issue in my laptop


Since the day, I upgraded from Windows 7 to Windows 8 Professional, my laptop was having serious wi-fi connectivity issue. It connects very fast, but gets disconnect in any near minute. And, it’s miserable as you can imagine.

I contacted HP support team twice, thrice, frice (does such a term exists?) only to make things more and more worse. In every support chat, I’s wasting merely one hour to complete their formalities and usual troubleshooting tips. Yes, they provide good support and showed good patience though and treated every support request nicely.

Keeping that aside, my problem was not solved though the support assistants updated my network drivers. Finally, an old school trick solved the wi-fi connectivity problem. However, there is something that made me think for the old school trick.

If you are a laptop user then I’m sure that you might have noticed the annoying auto-brightness adjustment of your screen. That’s simply one of the power management technique of the laptop. Since, laptops are designed handy to carry from one place to another, saving every bit of battery power is very crucial. One such feature is auto-brightness adjustment. In the similar way, there are various other ways a laptop “tries” to save the battery power. Of course, it includes network related activities also. “THIS” made me to think!!! And, I finally solved the wi-fi connectivity issue. Here it goes:

Try any of the below methods or both.

1.   Open Device Manager –> expand Network Adapter –> right-click and select Properties of your wi-fi adapter –> select tab: Power Management and uncheck “Allow the computer to turn off this device to save power

image

2.   From system-tray, click the battery meter/icon –> select More Power Options –>select Change plan settings of your current power plan –> select Change advanced power settings –> From Wireless Adapter Settings, set Maximum Performance for On battery and Plugged in mode.

image

image

image

image

Disconnect and connect again. That’s it Winking smile

Hope it helps.

Thanks.